Come aggiornare jQuery su Blogger per far funzionare tutti i widget


La libreria jQuery è indispensabile per ogni blog dove sono presenti effetti, animazioni e widget più personalizzati. Ho notato che molti blog su Blogger ne sono sprovvisti (compreso il mio) e questo comporta che tutti quei tutorial che permettono di inserire widget o meno speciali, cioè con parecchie funzionalità (si aprono, si chiudono, si muovono ecc) non risultano compatibili con il proprio modello.
Per rendere il proprio blog compatibile occorre aggiornare jQuery su Blogger così torneranno a funzionare tutti i widget.

Dovete andare su Modello > Modifica HTML e cercare il termine "jQuery", se lo trovate dovete verificare il numero della versione in quanto potrebbe essere vecchia dato che periodicamente ne escono altre più recenti.

Per aggiornarlo dovete sostituire l'URL del jQuery con il seguente:
https://ajax.googleapis.com/ajax/libs/jquery/2.1.3/jquery.min.js

Se invece la ricerca non ha portato alcun risultato significa che non avevate nemmeno la versione più vecchia ed in questo caso dovete cercare il tag <head> e dopo di esso dovete aggiungere il seguente codice:
<script src="//ajax.googleapis.com/ajax/libs/jquery/2.1.3/jquery.min.js"></script> 

Può darsi che mi sfuggirà di aggiornare la versione di jQuery inserita in questo post. Per sapere quale sia la versione più recente dovete recarvi sul sito Google Hosted Libraries e poi dovete prelevare il codice presente a fianco alla voce jQuery.

Per fare un esempio, su un articolo ho scritto come mettere il modulo di contatto in posizione flottante e senza l'aggiornamento di jQuery non sarebbe potuto funzionare.



Nessun commento :

Scrivi un commento

I commenti dovranno prima essere approvati da un amministratore. Verranno pubblicati solo quelli utili a tutti e attinenti al contenuto della pagina. Per commentare utilizzate un account Google/Gmail, altrimenti la modalità "anonimo".